Ford Fiesta ST Forum banner

1 - 20 of 57 Posts

·
Registered
Joined
·
83 Posts
Discussion Starter #1
This morning it's -20 here in southern ontario my wife was going to work and the heater system would not turn on at all?
Anybody have this happen to them?
Can't drive the car due to the windshield fogging up and freezing

Thanks
 

·
Registered
Joined
·
83 Posts
Discussion Starter #3
Thanks for the quick reply

The car will be at the dealer for about 6 days due to the parts being on back order.
Driving a 13 focus as a loner makes me already miss my car.
 

·
Registered
Joined
·
1,459 Posts
Thanks for the quick reply

The car will be at the dealer for about 6 days due to the parts being on back order.
Driving a 13 focus as a loner makes me already miss my car.
Look on the bright side.
If you get hit because of snow and ice in the next six days.
It WONT be your car.

Dave
 

·
Registered
Joined
·
283 Posts
This morning it's -20 here in southern ontario my wife was going to work and the heater system would not turn on at all?
Anybody have this happen to them?
Can't drive the car due to the windshield fogging up and freezing

Thanks
I
Live in Toronto. My car is parked outside.. No problems even when it was -35
 

·
Registered
Joined
·
282 Posts
I think the problem is if snow and ice gets into the heating vents through the windshield area which causes the blower to no function anymore and cause fuse to blow. I too am waiting for this part, my dealer has the ice shield piece, they are waiting for a special clip to install it which is back ordered.
 

·
Registered
Joined
·
46 Posts
I asked my dealer about the special clips being back ordered, and they claimed that they would reuse the existing retaining clips as long as they didnt break when they were removed. So far it's working fine, but now I'm a little worried that maybe my fix wasn't done correctly as it seems like everyone else's dealer is making them wait for the back order. Not sure if they did me a favor or not?
 

·
Registered
Joined
·
282 Posts
The only thing I would recommend as a temporary fix is to put a towel over the outside portion of the vents from preventing snow and ice from entering the vents when parked. My car gets garaged at night and I haven't experienced any issues as even if some snow gets in there it melts in the garage over night. We had some cold days here too.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
14 Posts
I had this happen to me this morning. At least it was only -5 degrees F. today! It would have been worse yesterday (-14F). I only discovered my blower wasn't working till I was a few miles from home. Man, that was a chilly 20 mile ride to work even with seat warmers on, I'm telling you. After I got feeling back in my hands and feet, I had a service writer bring my car into the shop and got it thawed out. The fuse wasn't blown, the tech thought the blower wheel was just frozen in the housing. I ordered the parts but they are both on a bad back order status. The retainers in the TSB are the same part number as the stock parts, so as long as they don't break they should be fine. I haven't seen them but I would think another retainer could be used in a pinch.
 

·
Registered
Joined
·
282 Posts
Dealer is Still waiting on the parts, the car has been at the dealer for 11 days now

I guess it's kinda like winter storage! :)
Hopefully your parts will show up soon, I've got an appointment this Thursday for my dealer to install the new ice shield and special back ordered clips. If my dealer can get the clips this probably means Ford is getting caught up on the back ordered parts.
 

·
Registered
Joined
·
282 Posts
Yes it is


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
282 Posts
They are installing a new ice shield cover and new clips, I would recommend anyone to get this done whether they have had issues or not. This issue is a design flaw by Ford. I never had any issues either, I complained to my dealer about this issue, although one time I had snow come in for a couple of seconds. I didn't want to wait till one day and I've got no heat and can't drive.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
283 Posts
They are installing a new ice shield cover and new clips, I would recommend anyone to get this done whether they have had issues or not. This issue is a design flaw by Ford. I never had any issues either, I complained to my dealer about this issue, although one time I had snow come in for a couple of seconds. I didn't want to wait till one day and I've got no heat and can't drive.


Sent from my iPhone using Tapatalk
Can you post a pic afterwards? Will call my dealer. My car sits on the streets. Had no problems in the -40 temps
 

·
Registered
Joined
·
282 Posts


Here's after the dealer installed the ice shields. I think these are what they added. I remember looking these before and seeing a big hole, maybe someone can confirm. Service rep at Dealer couldn't tell me where this ice shield and clips got installed.


Sent from my iPhone using Tapatalk
 
  • Like
Reactions: LuvfiestaST

·
Registered
Joined
·
282 Posts
I'm talking about the small strips below the foamy part


Sent from my iPhone using Tapatalk
 
1 - 20 of 57 Posts
Top